Mục lục bài viết || Contents of the article

    Apache Software Foundation vừa phát hành bản vá cho hai lỗ hổng tồn tại trong Apache HTTP Server. Trong đó, lỗ hổng zero-day CVE-2021-41773 liên quan đến lỗi truyền tải đường dẫn và lộ file trong máy chủ (a path traversal and file disclosure flaw) được cho là có khả năng ảnh hưởng tới gần 500 máy chủ tại Việt Nam.

    1. Về Apache và hai lỗ hổng bảo mật trên web server này

    1.1. Apache là phần mềm gì?

    Apache là phần mềm web server phổ biến nhất thế giới. Apache được phát triển bởi một cộng đồng mã nguồn mở dưới sự bảo trợ của Apache Software Foundation. Tính đến tháng 8 năm 2018, Apache ước tính phục vụ cho 54.2% các trang web đang hoạt động và 53.3% số máy chủ hàng đầu. Apache chạy trên các hệ điều hành như Windows, Unix, Linux, unix, Solaris…

    1.2. Về lỗ hổng zero-day CVE-2021-41773

    Lỗ hổng đầu tiên trên Apache có định danh CVE-2021-41773, là một lỗ hổng truyền tải đường dẫn tồn tại trong Apache HTTP Server 2.4.49. Thông qua lỗ hổng này, tin tặc có thể thực hiện một cuộc tấn công truyền tải đường dẫn mà “map” các URL tới các tệp bên ngoài thư mục gốc tài liệu dự kiến (expected document root), trừ khi các tài liệu này được bảo vệ bằng tính năng “từ chối tất cả yêu cầu” (require all denied). Bên cạnh đó, lỗ hổng nói trên cũng cho phép tin tặc làm làm rò rỉ nguồn của các tệp được thông dịch (interpreted file) như tập lệnh CGI.

    Một điểm lưu ý, lỗ hổng CVE-2021-41773 tồn tại trong phiên bản 2.4.49, đồng nghĩa các phiên bản trước đó không bị ảnh hưởng bởi lỗ hổng này. 

    1.3. Về lỗ hổng CVE-2021-41524 

    Lỗ hổng thứ hai ít nghiêm trọng hơn có định danh CVE-2021-41524. Lỗ hổng này liên quan đến con trỏ NULL và chỉ ảnh hưởng đến Apache HTTP Server 2.4.49. Qua lỗ hổng CVE-2021-41524, tin tặc có thể thực hiện các cuộc tấn công từ chối dịch vụ (DoS) trên máy chủ web thông qua các yêu cầu đặc biệt. 

    2. Ảnh hưởng lỗ hổng của CVE-2021-41773 đến các máy chủ tại Việt Nam 

    Theo ước tính, có gần 500 máy chủ tại Việt Nam chịu rủi ro bị tấn công bởi lỗ hổng CVE-2021-41773. Mức độ ảnh hưởng của lỗ hổng này cũng được đánh giá là khá nghiêm trọng. Bởi đây là lỗ hổng có thể làm lộ các thông tin nhạy cảm như: thư mục etc, password, system… Từ các thông tin này, tin tặc có thể dễ dàng tấn công vào hệ thống. 

    3. Cách giảm thiểu rủi ro tấn công mạng do lỗ hổng bảo mật trên Apache

    Để ngăn chặn các vụ tấn công mạng do hai lỗ hổng trên Apache, các tổ chức, doanh nghiệp cần cập nhật Apache HTTP Server phiên bản 2.4.50. Tuy nhiên, bản sửa lỗi trong Apache HTTP Server 2.4.50 chưa hoàn thiện. Vì vậy, sau khi cập nhật, các tổ chức, doanh nghiệp nên chủ động kiểm tra lại xem web server còn tồn tại lỗ hổng hay không. 

    Để làm được điều này, các tổ chức, doanh nghiệp cần một thiết bị rà quét có khả năng tìm ra hai lỗ hổng đó. Bằng cách tích hợp hai lỗ hổng trên Apache vào cơ sở dữ liệu lỗ hổng của mình, thiết bị SecurityBox 4NetworkSecurityBox 4Website có thể giúp doanh nghiệp phát hiện ra nếu chúng tồn tại trên hệ thống mạng. Từ đó, doanh nghiệp có thể kịp thời xử lý và ngăn chặn rủi ro triệt để. 

    Nếu doanh nghiệp cần tư vấn miễn phí về thiết bị của SecurityBox, hãy để lại thông tin tại form bên dưới. 

    Bài viết đề xuất || Recommended
    Trong thời kỳ chuyển đổi số đang phát triển mạnh mẽ như hiện nay, các doanh nghiệp tại ASEAN đang phải đối mặt liên tiếp với những thách thức về an...
    Panasonic - hãng sản xuất điện tử lớn nhất Nhật Bản vừa xác nhận hệ thống mạng của họ bị xâm nhập bất hợp pháp trong một cuộc tấn công. 1. Về...
    Với sự phát triển của công nghệ thông tin, việc tạo mật khẩu cho một tài khoản đăng nhập đã quá phổ biến. Nhưng có một câu hỏi đặt ra, liệu mật...
    Kiến thức | 24/11/2021